MyGame Panel experiencing degraded performance

Outage on US nodes

Resolved
Operational
Started about 2 years ago Lasted about 9 hours

Affected

Updates
  • Resolved
    Resolved

    This downtime has been resolved. We apologise again for any inconvenience caused.

  • Identified
    Identified

    Our staff are aware of the issue and are working to resolve it, ETA 2-5 hours. We sincerely apologise for anyone affected by this issue.

  • Investigating
    Investigating

    We're investigating an issue causing both US servers to be down, we will update this page with new info as soon as we can.