MyGame Panel experiencing degraded performance

Slowdowns on some websites

Resolved
Operational
Started about 2 years ago Lasted about 3 hours

Affected

Updates
  • Resolved
    Resolved

    We had a problem with the router in our Lisbon data centre, which was replaced by our technicians. Everything should be back to normal.

  • Investigating
    Investigating

    We're investigating an issue causing the myGame panels to be slow or not function at all. We will update this page as we continue our investigation.