MyGame Panel experiencing degraded performance

Outage on some servers

Resolved
Partial outage
Started almost 2 years ago Lasted 14 minutes

Affected

Updates
  • Resolved
    Resolved

    This incident has successfully been resolved and all affected sites are back up and running again.

  • Investigating
    Investigating

    We're currently investigating an issue with some of our frontend servers causing our panels to be down. We will update this page as soon as we receive more inforamtion.