MyGame Panel experiencing degraded performance

Outage on myGame Panels and Front Website

Resolved
Degraded performance
Started almost 2 years ago Lasted about 1 hour

Affected

Services
Website
Updates
  • Resolved
    Resolved

    This issue has been resolved and the affected sites are back up and running.

  • Identified
    Identified

    We've identified an issue resulting in the myGame panels and the front website page not loading. We believe this issue is due to Cloudflare and we are awaiting a fix. Customer services are not affected by this outage.