MyGame Panel experiencing degraded performance

Increased errors on myGame Game Panel

Resolved
Degraded performance
Started almost 2 years ago Lasted about 2 hours

Affected

Updates
  • Resolved
    Resolved

    We've successfully resolved this issue and the panel is back in full working order.

  • Investigating
    Investigating

    We're currently investigating an issue where customers are facing increased errors on the myGame Game Panel. Customer services are not affected by this outage.